To run this application, you first must install one of the following versions of the .NET Framework: v4.0.30319.

Error:
To run this application, you first must install one of the following versions of the .NET Framework: v4.0.30319.

Snap shot:

framework

Issue Observed:
Normally this issue occurs when u try to run an application which is targeted to Framework 4.0, and framework 4.0 is not installed on that PC.
If u have already installed framework 4.0, and still the issue is same follow the below steps.
Workaround 1:
⦁ If you have just installed Framework 4.0, and if u have not restarted the system, try once by restarting the system.
Workaround 2:
⦁ Navigate to SYSTEM 32 path , i.e; c:\Windows\System32, search for a file mscoree.dll, check the version of mscoree.dll , it should be as show below

framework1

Incase if dll of lower version is found, replace mscoree.dll of version show in the error above by providing required permission.

Workaround 3:

If mscoree.dll is of same version required, Repair installed framework from control panel [This is possible in WIN 7 & below operating system].

Leave a Reply

Your email address will not be published. Required fields are marked *